#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?(\d{5}|\d{2}(?=\d*\.\d*)[\d.]{3}\d)$"
Local $sString = "10.095" & @CRLF & _
"100.95" & @CRLF & _
"1009.5" & @CRLF & _
"10095" & @CRLF & _
"100955" & @CRLF & _
"1.0095" & @CRLF & _
"-1.0095" & @CRLF & _
"0.1009" & @CRLF & _
"0.10009"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")