use strict;
my $str = '10.095
100.95
1009.5
10095
100955
1.0095
-1.0095
0.1009
0.10009';
my $regex = qr/^-?(\d{5}|\d{2}(?=\d*\.\d*)[\d.]{3}\d)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}