import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?(\\d{5}|\\d{2}(?=\\d*\\.\\d*)[\\d.]{3}\\d)$";
final String string = "10.095\n"
+ "100.95\n"
+ "1009.5\n"
+ "10095\n"
+ "100955\n"
+ "1.0095\n"
+ "-1.0095\n"
+ "0.1009\n"
+ "0.10009";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}