$re = '/^-?(\d{5}|\d{2}(?=\d*\.\d*)[\d.]{3}\d)$/m';
$str = '10.095
100.95
1009.5
10095
100955
1.0095
-1.0095
0.1009
0.10009';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);