const regex = /^-?(\d{5}|\d{2}(?=\d*\.\d*)[\d.]{3}\d)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-?(\\d{5}|\\d{2}(?=\\d*\\.\\d*)[\\d.]{3}\\d)$', 'gm')
const str = `10.095
100.95
1009.5
10095
100955
1.0095
-1.0095
0.1009
0.10009`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}