using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?(\d{5}|\d{2}(?=\d*\.\d*)[\d.]{3}\d)$";
string input = @"10.095
100.95
1009.5
10095
100955
1.0095
-1.0095
0.1009
0.10009";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}