#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+[A-Z]?(?:,\d+[A-Z]?)*$"
Local $sString = "1" & @CRLF & _
"" & @CRLF & _
"12" & @CRLF & _
"" & @CRLF & _
"1A" & @CRLF & _
"" & @CRLF & _
"A1" & @CRLF & _
"" & @CRLF & _
"12A" & @CRLF & _
"" & @CRLF & _
"A12" & @CRLF & _
"" & @CRLF & _
"1AA" & @CRLF & _
"" & @CRLF & _
"A" & @CRLF & _
"" & @CRLF & _
"1,2,3,6A,6B,11,11A"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")