$re = '/^\d+[A-Z]?(?:,\d+[A-Z]?)*$/m';
$str = '1
12
1A
A1
12A
A12
1AA
A
1,2,3,6A,6B,11,11A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);