import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+[A-Z]?(?:,\\d+[A-Z]?)*$";
final String string = "1\n\n"
+ "12\n\n"
+ "1A\n\n"
+ "A1\n\n"
+ "12A\n\n"
+ "A12\n\n"
+ "1AA\n\n"
+ "A\n\n"
+ "1,2,3,6A,6B,11,11A";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}