// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+[A-Z]?(?:,\d+[A-Z]?)*$").unwrap();
let string = "1
12
1A
A1
12A
A12
1AA
A
1,2,3,6A,6B,11,11A";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}