using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+[A-Z]?(?:,\d+[A-Z]?)*$";
string input = @"1
12
1A
A1
12A
A12
1AA
A
1,2,3,6A,6B,11,11A";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}