re = /^\d+[A-Z]?(?:,\d+[A-Z]?)*$/m
str = '1
12
1A
A1
12A
A12
1AA
A
1,2,3,6A,6B,11,11A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end