package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+[A-Z]?(?:,\d+[A-Z]?)*$`)
var str = `1
12
1A
A1
12A
A12
1AA
A
1,2,3,6A,6B,11,11A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}