# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(?<=[^-<]|^)--(?=[^->])|-{4,}).*|(?<!-)-->>>.*//gm;t' <<< "-- test
test1 -- test
--->>> test
<<<--- test
--->>>->>> test
---->>> test
test --->>> test
test --->>> test <<<---
-->>> test"