$re = '/(?:(?<=[^-<]|^)--(?=[^->])|-{4,}).*|(?<!-)-->>>.*/m';
$str = '-- test
test1 -- test
--->>> test
<<<--- test
--->>>->>> test
---->>> test
test --->>> test
test --->>> test <<<---
-->>> test';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;