use strict;
my $str = '-- test
test1 -- test
--->>> test
<<<--- test
--->>>->>> test
---->>> test
test --->>> test
test --->>> test <<<---
-->>> test';
my $regex = qr/(?:(?<=[^-<]|^)--(?=[^->])|-{4,}).*|(?<!-)-->>>.*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";