import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<=[^-<]|^)--(?=[^->])|-{4,}).*|(?<!-)-->>>.*";
final String string = "-- test\n"
+ "test1 -- test\n"
+ "--->>> test\n"
+ "<<<--- test\n"
+ "--->>>->>> test\n"
+ "---->>> test\n"
+ "test --->>> test\n"
+ "test --->>> test <<<---\n"
+ "-->>> test";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}