using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=[^-<]|^)--(?=[^->])|-{4,}).*|(?<!-)-->>>.*";
string substitution = @"";
string input = @"-- test
test1 -- test
--->>> test
<<<--- test
--->>>->>> test
---->>> test
test --->>> test
test --->>> test <<<---
-->>> test";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}