#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(?<=[^-<]|^)--(?=[^->])|-{4,}).*|(?<!-)-->>>.*"
Local $sString = "-- test" & @CRLF & _
"test1 -- test" & @CRLF & _
"--->>> test" & @CRLF & _
"<<<--- test" & @CRLF & _
"--->>>->>> test" & @CRLF & _
"---->>> test" & @CRLF & _
"test --->>> test" & @CRLF & _
"test --->>> test <<<---" & @CRLF & _
"-->>> test"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)