const regex = /(?:(?<=[^-<]|^)--(?=[^->])|-{4,}).*|(?<!-)-->>>.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<=[^-<]|^)--(?=[^->])|-{4,}).*|(?<!-)-->>>.*', 'gm')
const str = `-- test
test1 -- test
--->>> test
<<<--- test
--->>>->>> test
---->>> test
test --->>> test
test --->>> test <<<---
-->>> test`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);