using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(((((0|27)\d{9})|00\d{11,14}))|(\d{3,4}))$";
string input = @"0820001234
27820001234
0027820001234
1000
100
asdgfda
12345
2785666";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}