import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((((0|27)\\d{9})|00\\d{11,14}))|(\\d{3,4}))$";
final String string = "0820001234\n"
+ "27820001234\n"
+ "0027820001234\n"
+ "1000\n"
+ "100\n\n"
+ "asdgfda\n"
+ "12345\n"
+ "2785666";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}