package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(((((0|27)\d{9})|00\d{11,14}))|(\d{3,4}))$`)
var str = `0820001234
27820001234
0027820001234
1000
100
asdgfda
12345
2785666`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}