const regex = /^(((((0|27)\d{9})|00\d{11,14}))|(\d{3,4}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((((0|27)\\d{9})|00\\d{11,14}))|(\\d{3,4}))$', 'gm')
const str = `0820001234
27820001234
0027820001234
1000
100
asdgfda
12345
2785666`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}