$re = '/^(((((0|27)\d{9})|00\d{11,14}))|(\d{3,4}))$/m';
$str = '0820001234
27820001234
0027820001234
1000
100
asdgfda
12345
2785666';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);