use strict;
my $str = '0820001234
27820001234
0027820001234
1000
100
asdgfda
12345
2785666';
my $regex = qr/^(((((0|27)\d{9})|00\d{11,14}))|(\d{3,4}))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}