// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(((((0|27)\d{9})|00\d{11,14}))|(\d{3,4}))$").unwrap();
let string = "0820001234
27820001234
0027820001234
1000
100
asdgfda
12345
2785666";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}