#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(([A-Za-z0-9]+\w*[\.\-]?){1,}+\w*@([A-Za-z0-9]+\.){1,2}[A-z]{2,3})"
Local $sString = "Outbound","1F280088DCA6184493AB7BDEE13D21022DD048CF@HOR-P1-MBX4.visanet.corp","RES:_Grupo_Especial_para_Quem_é_Especial","vanderleysilva@shconsorcio.com.br","raffael.vargas@cielo.com.br",2015-05-27 12:54:26,65636,2015-05-27 12:54:26,"Nenhum","Cabeçalho adicionado",",2,"Êxito mail1.prestadorcbmp.com.br"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")