const regex = /(([A-Za-z0-9]+\w*[\.\-]?){1,}+\w*@([A-Za-z0-9]+\.){1,2}[A-z]{2,3})/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([A-Za-z0-9]+\\w*[\\.\\-]?){1,}+\\w*@([A-Za-z0-9]+\\.){1,2}[A-z]{2,3})', 'gi')
const str = `Outbound","1F280088DCA6184493AB7BDEE13D21022DD048CF@HOR-P1-MBX4.visanet.corp","RES:_Grupo_Especial_para_Quem_é_Especial","vanderleysilva@shconsorcio.com.br","raffael.vargas@cielo.com.br",2015-05-27 12:54:26,65636,2015-05-27 12:54:26,"Nenhum","Cabeçalho adicionado",",2,"Êxito mail1.prestadorcbmp.com.br`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}