re = /(([A-Za-z0-9]+\w*[\.\-]?){1,}+\w*@([A-Za-z0-9]+\.){1,2}[A-z]{2,3})/i
str = 'Outbound","1F280088DCA6184493AB7BDEE13D21022DD048CF@HOR-P1-MBX4.visanet.corp","RES:_Grupo_Especial_para_Quem_é_Especial","vanderleysilva@shconsorcio.com.br","raffael.vargas@cielo.com.br",2015-05-27 12:54:26,65636,2015-05-27 12:54:26,"Nenhum","Cabeçalho adicionado",",2,"Êxito mail1.prestadorcbmp.com.br'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end