import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([A-Za-z0-9]+\\w*[\\.\\-]?){1,}+\\w*@([A-Za-z0-9]+\\.){1,2}[A-z]{2,3})";
final String string = "Outbound\",\"1F280088DCA6184493AB7BDEE13D21022DD048CF@HOR-P1-MBX4.visanet.corp\",\"RES:_Grupo_Especial_para_Quem_é_Especial\",\"vanderleysilva@shconsorcio.com.br\",\"raffael.vargas@cielo.com.br\",2015-05-27 12:54:26,65636,2015-05-27 12:54:26,\"Nenhum\",\"Cabeçalho adicionado\",\",2,\"Êxito mail1.prestadorcbmp.com.br";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}