import re
regex = re.compile(r"(([A-Za-z0-9]+\w*[\.\-]?){1,}+\w*@([A-Za-z0-9]+\.){1,2}[A-z]{2,3})", flags=re.IGNORECASE)
test_str = "Outbound\",\"1F280088DCA6184493AB7BDEE13D21022DD048CF@HOR-P1-MBX4.visanet.corp\",\"RES:_Grupo_Especial_para_Quem_é_Especial\",\"vanderleysilva@shconsorcio.com.br\",\"raffael.vargas@cielo.com.br\",2015-05-27 12:54:26,65636,2015-05-27 12:54:26,\"Nenhum\",\"Cabeçalho adicionado\",\",2,\"Êxito mail1.prestadorcbmp.com.br"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")