// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(([A-Za-z0-9]+\w*[\.\-]?){1,}+\w*@([A-Za-z0-9]+\.){1,2}[A-z]{2,3})").unwrap();
let string = "Outbound\",\"1F280088DCA6184493AB7BDEE13D21022DD048CF@HOR-P1-MBX4.visanet.corp\",\"RES:_Grupo_Especial_para_Quem_é_Especial\",\"vanderleysilva@shconsorcio.com.br\",\"raffael.vargas@cielo.com.br\",2015-05-27 12:54:26,65636,2015-05-27 12:54:26,\"Nenhum\",\"Cabeçalho adicionado\",\",2,\"Êxito mail1.prestadorcbmp.com.br";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}