import Foundation
let pattern = #"(([A-Za-z0-9]+\w*[\.\-]?){1,}+\w*@([A-Za-z0-9]+\.){1,2}[A-z]{2,3})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"Outbound","1F280088DCA6184493AB7BDEE13D21022DD048CF@HOR-P1-MBX4.visanet.corp","RES:_Grupo_Especial_para_Quem_é_Especial","vanderleysilva@shconsorcio.com.br","raffael.vargas@cielo.com.br",2015-05-27 12:54:26,65636,2015-05-27 12:54:26,"Nenhum","Cabeçalho adicionado",",2,"Êxito mail1.prestadorcbmp.com.br"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)