#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/mobile\.aspx\?data=(\d+)&p=1"
Local $sString = "/mobile.aspx?data=10&p=1" & @CRLF & _
"/mobile.aspx?data=130&p=1" & @CRLF & _
"/mobile.aspx?data=140&p=1" & @CRLF & _
"/mobile.aspx?data=133&p=1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")