$re = '/\/mobile\.aspx\?data=(\d+)&p=1/m';
$str = '/mobile.aspx?data=10&p=1
/mobile.aspx?data=130&p=1
/mobile.aspx?data=140&p=1
/mobile.aspx?data=133&p=1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);