use strict;
my $str = '/mobile.aspx?data=10&p=1
/mobile.aspx?data=130&p=1
/mobile.aspx?data=140&p=1
/mobile.aspx?data=133&p=1';
my $regex = qr/\/mobile\.aspx\?data=(\d+)&p=1/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}