import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/mobile\\.aspx\\?data=(\\d+)&p=1";
final String string = "/mobile.aspx?data=10&p=1\n"
+ "/mobile.aspx?data=130&p=1\n"
+ "/mobile.aspx?data=140&p=1\n"
+ "/mobile.aspx?data=133&p=1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}