re = /\/mobile\.aspx\?data=(\d+)&p=1/m
str = '/mobile.aspx?data=10&p=1
/mobile.aspx?data=130&p=1
/mobile.aspx?data=140&p=1
/mobile.aspx?data=133&p=1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end