package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/mobile\.aspx\?data=(\d+)&p=1`)
var str = `/mobile.aspx?data=10&p=1
/mobile.aspx?data=130&p=1
/mobile.aspx?data=140&p=1
/mobile.aspx?data=133&p=1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}