const regex = /\/mobile\.aspx\?data=(\d+)&p=1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/mobile\\.aspx\\?data=(\\d+)&p=1', 'gm')
const str = `/mobile.aspx?data=10&p=1
/mobile.aspx?data=130&p=1
/mobile.aspx?data=140&p=1
/mobile.aspx?data=133&p=1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}