using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:'|\G(?!^))\s(?=\s*')'?";
string substitution = @"CHR\(32\)";
string input = @"vpl_text := to_char(vpl_text_old) || ' ' ||...;
vpl_text := to_char(vpl_text_old) || '' ||...;";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}