import Foundation
let pattern = #"(?:'|\G(?!^))\s(?=\s*')'?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
vpl_text := to_char(vpl_text_old) || ' ' ||...;
vpl_text := to_char(vpl_text_old) || '' ||...;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"CHR\(32\)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)