$re = '/(?:\'|\G(?!^))\s(?=\s*\')\'?/';
$str = 'vpl_text := to_char(vpl_text_old) || \' \' ||...;
vpl_text := to_char(vpl_text_old) || \'\' ||...;';
$subst = "CHR\(32\)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;