re = /(?:'|\G(?!^))\s(?=\s*')'?/
str = 'vpl_text := to_char(vpl_text_old) || \' \' ||...;
vpl_text := to_char(vpl_text_old) || \'\' ||...;'
subst = 'CHR\\(32\\)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result