#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:https?:\/\/)?[^\/\s]*\.([^.\s\/]*\.[^.\s\/]*)(?:$|\/.*)"
Local $sString = "http://therealzenstar.blogspot.fr" & @CRLF & _
"http://therealzenstar.blogspot.fr/" & @CRLF & _
"http://therealzenstar.blogspot.fr/some_test.domain.html" & @CRLF & _
"http://therealzenstar.blogspot.co.uk/some_test.domain.html"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)