// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:https?:\/\/)?[^\/\s]*\.([^.\s\/]*\.[^.\s\/]*)(?:$|\/.*)").unwrap();
let string = "http://therealzenstar.blogspot.fr
http://therealzenstar.blogspot.fr/
http://therealzenstar.blogspot.fr/some_test.domain.html
http://therealzenstar.blogspot.co.uk/some_test.domain.html";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}