import re
regex = re.compile(r"^(?:https?:\/\/)?[^\/\s]*\.([^.\s\/]*\.[^.\s\/]*)(?:$|\/.*)", flags=re.MULTILINE)
test_str = ("http://therealzenstar.blogspot.fr\n"
"http://therealzenstar.blogspot.fr/\n"
"http://therealzenstar.blogspot.fr/some_test.domain.html\n"
"http://therealzenstar.blogspot.co.uk/some_test.domain.html")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)