re = /^(?:https?:\/\/)?[^\/\s]*\.([^.\s\/]*\.[^.\s\/]*)(?:$|\/.*)/m
str = 'http://therealzenstar.blogspot.fr
http://therealzenstar.blogspot.fr/
http://therealzenstar.blogspot.fr/some_test.domain.html
http://therealzenstar.blogspot.co.uk/some_test.domain.html'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result