import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/)?[^\\/\\s]*\\.([^.\\s\\/]*\\.[^.\\s\\/]*)(?:$|\\/.*)";
final String string = "http://therealzenstar.blogspot.fr\n"
+ "http://therealzenstar.blogspot.fr/\n"
+ "http://therealzenstar.blogspot.fr/some_test.domain.html\n"
+ "http://therealzenstar.blogspot.co.uk/some_test.domain.html";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}